yum でインストールで「Protected multilib versions・・・」のエラー

yumで「rrdtool」をインストールしようとしたら下記のエラーがあがり「rrdtool」でインストール出来ませんでした。

$ yum install rrdtool

Protected multilib versions: rrdtool-1.3.8-10.el6.i686 != rrdtool-1.4.7-1.el6.rfx.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

rrdtool-1.3.8系が既にインストールされており、rrdtool-1.4.7系をインストールしようとするとrrdtool-1.3.8系が原因でインストールできないので、rrdtool-1.4.7系をインストールする前にrrdtool-1.3.8系を削除します

$ sudo yum remove rrdtool
Dependencies Resolved

rrdtoolが削除できたら、再度、rrdtoolをインストールします

$ yum install rrdtool

 

スポンサーリンク